Problemas com o provisionamento com PUPHPET e Vagrant

Depois de alguns dias tentando resolver um problema na instalação de pacotes usando o PUPHPET no Vagrant, descobri o problema:

Ao dar o comando vagrant up recebia diversas mensagens de erro como essas:

:::bash
Error: Could not find class ::ntp for packer-virtualbox.vagrantup.com on node packer-virtualbox.vagrantup.com

ou

:::bash
"Could not find declared class apt"

A solução foi simplesmente mudar o arquivo puppet/Puppetfile, mudando onde é git:// para https://, pois aqui na minha empresa o protocolo git:  estava bloqueado. Espero poder ajudar outras pessoas que tiveram o mesmo problema.

comments powered by Disqus